Sunday, February 27, 2011

EIGRP & OSPF Mutual Redistribution

There are two network types exist in this lab; EIGRP 100 and OSPF
Both internal and external routes will redistribute each other through R2 and R3.

Download complete GNS3 lab files from https://docs.google.com/leaf?id=0B889ogd4ltI2OWUwOTIxZjQtNGVmYS00M2FlLWI2MjEtZDI5MzVlNmRiYWVk&hl=en&authkey=CITduiY

Here is lab topology



















The lab objectives are as follow;






The main point of this lab is how to block the routes from EIGRP network  pass through R2 and R3 not to inject back to EIGRP as external routes.
At the same time, how to prevent routes from OSPF network redistributed to EIGRP through R3 and R2 to inject back to OSPF as external routes.

All of the above two goals are achieve by using route-map and access-lists in both R2 and R3.

(1) Check R2's EIGRP to OSPF redistribution

router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.12.0 0.0.0.255 area 0

Let's check route-map EIGRP-TO-OSPF
------------------------
route-map EIGRP-TO-OSPF deny 5
 match tag 40
!
route-map EIGRP-TO-OSPF permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map EIGRP-TO-OSPF permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map EIGRP-TO-OSPF deny 30
 match ip address 3
!
route-map EIGRP-TO-OSPF permit 40
 set metric 300
 set tag 30
-----------------------------------------
Interstringly, match tag 40 is deny. Let's see detail of tag 40. Tag 40 is the redistribute routes from OSPF to EIGRP through R2 and R3.
All the access list used for redistrubtion of EIGRP to OSPF are using tag 10 for (10.4.0.0, 10.4.1.0), tag 20 (10.4.2.0, 10.4.3.0) and tag 30
for others.

access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
=====================

Route-map configuration for redistrubution from OSPF to EIGRP in R2 are as follow;

route-map OSPF-TO-EIGRP deny 5
 match tag 10 20 30
!
(* The above route-map is for blocking networks from EIGRP to injecting to network itself.)

route-map OSPF-TO-EIGRP permit 10
 set metric 400 20 255 1 1500
 set tag 40
---------------

router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.12.0 0.0.0.255 area 0


======================================================
Let's start in R3 configutation in detail. All of the route-maps and configurtation will be the same as in R2 as the lab demonstrate for mutual redistrubution.
Route configurations are as follow;

router eigrp 100
 redistribute ospf 1 route-map OSPF-TO-EIGRP
 network 10.1.23.0 0.0.0.255
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.13.0 0.0.0.255 area 0
-------------------
Route-map configuation are as follow;

route-map EIGRP-TO-OSPF deny 5
 match tag 40
!
route-map EIGRP-TO-OSPF permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map EIGRP-TO-OSPF permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map EIGRP-TO-OSPF deny 30
 match ip address 3
!
route-map EIGRP-TO-OSPF permit 40
 set metric 300
 set tag 30
!
route-map OSPF-TO-EIGRP deny 5
 match tag 10 20 30
!
route-map OSPF-TO-EIGRP permit 10
 set metric 400 20 255 1 1500
 set tag 40

==========================================
Final goal of the lab can achive as follow;

To reach R1's loopback 10.1.0.0 network from R4, default path is R4-R2-R1. Instead of using this path, how to establish to achive as the path
R4-R2-R3-R1. The solution is to change the advertised EIGRP distance from 110 to 105.

Configuration in R2 is as follow;

router eigrp 100
 redistribute ospf 1 route-map OSPF-TO-EIGRP
 network 10.1.23.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 distance eigrp 90 105
 no auto-summary
======================

Checking whether routes are going as R4-R2-R3-R1 path using traceroute in R4 as follow;

R4#traceroute 10.1.0.1


Type escape sequence to abort.
Tracing the route to 10.1.0.1


  1 10.1.24.2 52 msec 32 msec 40 msec
  2 10.1.23.3 48 msec 32 msec 28 msec
  3 10.1.13.1 52 msec *  76 msec
=======================

Route in R2 are as follow.

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
D EX    10.1.13.0/24 [105/6917120] via 10.1.23.3, 00:47:56, Serial1/1
C       10.1.12.0/24 is directly connected, Serial1/0
D       10.4.4.0/24 [90/2297856] via 10.1.24.4, 00:47:56, Serial1/2
D EX    10.1.0.1/32 [105/6917120] via 10.1.23.3, 00:47:54, Serial1/1
D       10.4.2.0/24 [90/2297856] via 10.1.24.4, 00:47:56, Serial1/2
D       10.4.3.0/24 [90/2297856] via 10.1.24.4, 00:47:56, Serial1/2
D       10.4.0.0/24 [90/2297856] via 10.1.24.4, 00:47:56, Serial1/2
D       10.4.1.0/24 [90/2297856] via 10.1.24.4, 00:47:56, Serial1/2
C       10.1.24.0/24 is directly connected, Serial1/2
C       10.1.23.0/24 is directly connected, Serial1/1
-------------------------
Route in R3 are as follow;

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C       10.1.13.0/24 is directly connected, Serial1/0
O       10.1.12.0/24 [110/128] via 10.1.13.1, 00:48:27, Serial1/0
D       10.4.4.0/24 [90/2809856] via 10.1.23.2, 00:48:28, Serial1/1
O       10.1.0.1/32 [110/65] via 10.1.13.1, 00:48:27, Serial1/0
D       10.4.2.0/24 [90/2809856] via 10.1.23.2, 00:48:28, Serial1/1
D       10.4.3.0/24 [90/2809856] via 10.1.23.2, 00:48:28, Serial1/1
D       10.4.0.0/24 [90/2809856] via 10.1.23.2, 00:48:28, Serial1/1
D       10.4.1.0/24 [90/2809856] via 10.1.23.2, 00:48:28, Serial1/1
D       10.1.24.0/24 [90/2681856] via 10.1.23.2, 00:48:28, Serial1/1
C       10.1.23.0/24 is directly connected, Serial1/1
---------------------

Route in R4 (EIGRP) are as follow;

     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
D EX    10.1.13.0/24 [170/7429120] via 10.1.24.2, 00:49:16, Serial1/0
D EX    10.1.12.0/24 [170/6917120] via 10.1.24.2, 00:49:16, Serial1/0
C       10.4.4.0/24 is directly connected, Loopback4
D EX    10.1.0.1/32 [170/7429120] via 10.1.24.2, 00:49:14, Serial1/0
C       10.4.2.0/24 is directly connected, Loopback2
C       10.4.3.0/24 is directly connected, Loopback3
C       10.4.0.0/24 is directly connected, Loopback0
C       10.4.1.0/24 is directly connected, Loopback1
C       10.1.24.0/24 is directly connected, Serial1/0
D       10.1.23.0/24 [90/2681856] via 10.1.24.2, 00:49:16, Serial1/0

-----------------------
Route in R1 (OSPF) are as follow. As there are two routes path receiving external routers, R2 and R3, two load balacing paths are found.

     10.0.0.0/24 is subnetted, 9 subnets
C       10.1.13.0 is directly connected, Serial1/1
C       10.1.12.0 is directly connected, Serial1/0
C       10.1.0.0 is directly connected, Loopback0
O E2    10.4.2.0 [110/200] via 10.1.13.3, 00:49:37, Serial1/1
                 [110/200] via 10.1.12.2, 00:49:37, Serial1/0
O E2    10.4.3.0 [110/200] via 10.1.13.3, 00:49:37, Serial1/1
                 [110/200] via 10.1.12.2, 00:49:37, Serial1/0
O E2    10.4.0.0 [110/100] via 10.1.13.3, 00:49:37, Serial1/1
                 [110/100] via 10.1.12.2, 00:49:37, Serial1/0
O E2    10.4.1.0 [110/100] via 10.1.13.3, 00:49:37, Serial1/1
                 [110/100] via 10.1.12.2, 00:49:37, Serial1/0
O E2    10.1.24.0 [110/300] via 10.1.12.2, 00:49:37, Serial1/0
                  [110/300] via 10.1.13.3, 00:49:37, Serial1/1
O E2    10.1.23.0 [110/300] via 10.1.12.2, 00:49:38, Serial1/0
                  [110/300] via 10.1.13.3, 00:49:38, Serial1/1

Saturday, February 12, 2011

Route Redistribution (EIGRP & OSPF)

I have watched through route redistribution video from CBT and it's really good and easy to understand.

Here is lab topology and objective. Download the complete GNS3 lab file from https://docs.google.com/leaf?id=0B889ogd4ltI2MWVlNjJmZWUtN2I2MS00NjA0LTk3M2EtYzVhOWVlNmI2MDg5&hl=en&authkey=CKTH6O0E
























Objectives are as follow:

-------------------
The main points of the labs are as follow:

  • Redistribute routes including external loopback routes from EIGRP AS 100 to OSPF and OSPF to EIGRP.
  • But when EIGRP redistribute route to OSPF, default metric is 20 because external route to OSPF are set as 20.
  • But when OSPF redistribute routes to EIGRP, default is infinite in EIGRP AS 100 and you can't see external routes even though using "redistribute ospf 1". To correct the problem define the five K-values metrics.
  • In addition, you can restrict route redistribution by setting access-list from EIGRP to OSPF.
  • But lab illustrate restrict redistribution from OSPF to EIGRP using ip prefix-list and allow only prefix list equal and less than 24.  So, three networks (10.1.11.0/30 , 10.1.11.5/30 and 10.1.11.9/30) are excluded.

Friday, February 11, 2011

EIGRP Redistribution





This is the question from CCNP route exam which I got from Digitaltut. I have created as GNS3 file for practicing.

There are three OSPF areas including Area 0 and one EIGRP AS 100 networks.
Goal is try to reach R2's  s1/0 interface from R4.

The point to test in exam is how you understand about redistribution.
I'm not sure exactly about original exam  questsion but I have added Area 0 by myself. If not it doesn't make senese to reach to R2's s1/0 interface.

Download complete lab from here.
https://docs.google.com/leaf?id=0B889ogd4ltI2NWQ2NGFjMWYtOTUwMy00NDI3LTgzNWItNTRiNWZmZTRkMjkz&hl=en&authkey=CNeu1b4D

First thing to know is all OSPF areas 24 and 34 are already configured.
EIGRP 100 has configured in R4-R3-R5.

Two redistrubution points;
(1) From R3's s1/2 (EIGRP 100) to OSPF area 24
(2) From R5's f0/0 (EIGRP 100) to OSPF area 34

The main point to note is check the K values of s1/2 of R3 and fa0/0 of R5 before redstribution.
How to check? Use "sh interface s1/2"

R3#sh int s1/2
Serial1/2 is up, line protocol is up 
  Hardware is M4T
  Internet address is 192.168.3.3/24
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
--------------------------------
Here are the things to note. BW is 1544, Delay is 20000 usec (2000 msec), reliability is 255, load is 1 and MTU is 1500.
So, the command to redistrube is as follow;
redistribute ospf 1 metric 1544 2000 255 1 1500
==========
But, checking in R5's fa0/0 will get different value because of it's fast ethernet interface. Check it out.

R5#sh int fa0/0
FastEthernet0/0 is up, line protocol is up 
  Hardware is Gt96k FE, address is c001.0aaa.0000 (bia c001.0aaa.0000)
  Internet address is 192.168.4.5/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
------------------
As you see, K values are as follows;
MTU 1500, Bandwidth is 100000 , Delay is 10 msec, reliabiliy is 255 and load is 1.
------------
All know that EIGRP's metric value calculation is only K1 and K3. It means it is only account only bandwidth and delay.
Here is the command to use for redistrubtion of EIGRP routes to OSPF area 34;
redistribute ospf 1 metric 100000 10 255 1 1500
-------------
In the mean time, when redistrubtion of EIGRP routes, pay attendtion to whether E1 or E2 types.
In short, E1 means metric will increase along it paths but E2 has constant value.
-----------
How to check whether route is E1 or E2 type.
It's simple. If you don't type any metric type, default is E2. To redistribute as E1, type "metric-type 1"
-----------
Check how it increase if the metric-type set to E1 in R2 and R1.
In R2's route table, both E1 routes have feasible distance 21.

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, FastEthernet0/0
C    192.168.4.0/24 is directly connected, FastEthernet0/1
O E1 192.168.1.0/24 [110/21] via 192.168.4.5, 00:24:44, FastEthernet0/1
O E1 192.168.2.0/24 [110/21] via 192.168.4.5, 00:24:44, FastEthernet0/1
C    192.168.3.0/24 is directly connected, Serial1/0
------------------
Let's check in R1. Feasible distance increased from 21 to 22 due to Fast Ethernet interface between two routers.
Also take note that default cost  for all redistribute external route (in this case , it is EIGRP AS 100) to OSPF is 20. That's why, in R3, it is appearing as 21 and in R1, it is 22.

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/2] via 172.16.100.2, 00:26:42, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/2] via 172.16.100.2, 00:26:42, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, FastEthernet0/0
O IA 192.168.4.0/24 [110/2] via 172.16.100.2, 00:26:42, FastEthernet0/0
O E1 192.168.1.0/24 [110/22] via 172.16.100.2, 00:26:42, FastEthernet0/0
O E1 192.168.2.0/24 [110/22] via 172.16.100.2, 00:26:42, FastEthernet0/0
O IA 192.168.3.0/24 [110/65] via 172.16.100.2, 00:26:42, FastEthernet0/0

Tuesday, February 8, 2011

EIGRP Stubs

Let's play EIGRP stubs today. All will know how to configure EIGRP router. It's really easy by typing two commands ; "eigrp 123" and announcing network number.

But, stub is not a familiar term and I have prepare lab for testing different terms of stub networks and how it will effect the routing.

Below is the topology picture. All are configured in my GNS3 lab with "eigrp stub" configuration. Try to test using different "eigrp stub" commands.

Download completed GNS3 file from here https://docs.google.com/leaf?id=0B889ogd4ltI2NGFiZDZmYjMtOGJlNC00YWYwLTlkYzktMzA1YzZlN2MzNmM1&hl=en&authkey=CLH03cYI



Four networks and R3 is for testing stub router.

R1 routes:


     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/2300416] via 10.2.3.2, 00:00:18, Serial1/0
     100.0.0.0/24 is subnetted, 1 subnets
D       100.100.100.0 [90/2174976] via 10.2.3.2, 00:00:18, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2172416] via 10.2.3.2, 00:00:18, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.30.0.0/21 [90/2300416] via 10.2.3.2, 00:00:18, Serial1/0
D       172.30.8.0/24 [90/2300416] via 10.2.3.2, 00:00:18, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2172416] via 10.2.3.2, 00:46:33, Serial1/0
C       10.2.3.0 is directly connected, Serial1/0

Noted that there is already summary route for 172.30 networks because I did summary address injected to EIGRP for stub network testing.

The original R1 routing table will be like this.

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/2300416] via 10.2.3.2, 00:00:01, Serial1/0
     100.0.0.0/24 is subnetted, 1 subnets
D       100.100.100.0 [90/2174976] via 10.2.3.2, 00:00:01, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2172416] via 10.2.3.2, 00:00:01, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     172.30.0.0/24 is subnetted, 9 subnets
D       172.30.2.0 [90/2300416] via 10.2.3.2, 00:00:01, Serial1/0
D       172.30.3.0 [90/2300416] via 10.2.3.2, 00:00:01, Serial1/0
D       172.30.0.0 [90/2300416] via 10.2.3.2, 00:00:01, Serial1/0
D       172.30.1.0 [90/2300416] via 10.2.3.2, 00:00:01, Serial1/0
D       172.30.6.0 [90/2300416] via 10.2.3.2, 00:00:02, Serial1/0
D       172.30.7.0 [90/2300416] via 10.2.3.2, 00:00:02, Serial1/0
D       172.30.4.0 [90/2300416] via 10.2.3.2, 00:00:02, Serial1/0
D       172.30.5.0 [90/2300416] via 10.2.3.2, 00:00:02, Serial1/0
D       172.30.8.0 [90/2300416] via 10.2.3.2, 00:00:02, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2172416] via 10.2.3.2, 00:50:14, Serial1/0
C       10.2.3.0 is directly connected, Serial1/0

---------------------------------

R2 Routes:

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/156160] via 10.2.2.3, 00:00:10, FastEthernet0/1
     100.0.0.0/24 is subnetted, 1 subnets
D       100.100.100.0 [90/30720] via 10.2.2.3, 00:00:10, FastEthernet0/1
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/28160] via 10.2.2.3, 00:00:10, FastEthernet0/1
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/2172416] via 10.2.3.1, 00:51:16, Serial1/0
     172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.30.0.0/21 [90/156160] via 10.2.2.3, 00:00:10, FastEthernet0/1
D       172.30.8.0/24 [90/156160] via 10.2.2.3, 00:00:10, FastEthernet0/1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.2.2.0 is directly connected, FastEthernet0/1
C       10.2.3.0 is directly connected, Serial1/0
---------------------------------

R3 Routes:

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback2
     100.0.0.0/24 is subnetted, 1 subnets
C       100.100.100.0 is directly connected, FastEthernet0/1
     3.0.0.0/32 is subnetted, 1 subnets
S       3.3.3.3 is directly connected, Null0
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/2174976] via 10.2.2.1, 00:00:33, FastEthernet0/0
     172.30.0.0/16 is variably subnetted, 10 subnets, 2 masks
C       172.30.2.0/24 is directly connected, Loopback5
C       172.30.3.0/24 is directly connected, Loopback6
C       172.30.0.0/24 is directly connected, Loopback3
D       172.30.0.0/21 is a summary, 00:00:38, Null0
C       172.30.1.0/24 is directly connected, Loopback4
C       172.30.6.0/24 is directly connected, Loopback9
C       172.30.7.0/24 is directly connected, Loopback10
C       172.30.4.0/24 is directly connected, Loopback7
C       172.30.5.0/24 is directly connected, Loopback8
C       172.30.8.0/24 is directly connected, Loopback11
     10.0.0.0/24 is subnetted, 2 subnets
C       10.2.2.0 is directly connected, FastEthernet0/0
D       10.2.3.0 [90/2172416] via 10.2.2.1, 00:00:34, FastEthernet0/0
---------------------------------------------------

R4 routes:

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/2302976] via 172.16.1.1, 00:01:04, FastEthernet0/0
     100.0.0.0/24 is subnetted, 1 subnets
D       100.100.100.0 [90/2177536] via 172.16.1.1, 00:01:04, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2174976] via 172.16.1.1, 00:01:04, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.30.0.0/21 [90/2302976] via 172.16.1.1, 00:01:04, FastEthernet0/0
D       172.30.8.0/24 [90/2302976] via 172.16.1.1, 00:01:04, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2174976] via 172.16.1.1, 00:13:42, FastEthernet0/0
D       10.2.3.0 [90/2172416] via 172.16.1.1, 00:13:42, FastEthernet0/0
-------------------------------

R5 routes:

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
     100.0.0.0/24 is subnetted, 1 subnets
C       100.100.100.0 is directly connected, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/28160] via 100.100.100.3, 00:06:20, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.1.0 [90/2177536] via 100.100.100.3, 00:01:29, FastEthernet0/0
     172.30.0.0/24 is subnetted, 9 subnets
D       172.30.2.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.3.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.0.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.1.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.6.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.7.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.4.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.5.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       172.30.8.0 [90/156160] via 100.100.100.3, 00:06:20, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/30720] via 100.100.100.3, 00:06:20, FastEthernet0/0
D       10.2.3.0 [90/2174976] via 100.100.100.3, 00:01:30, FastEthernet0/0
---------------------------
OK, let's start play EIGRP stub routes.

(1) First, let's start with eigrp stub command in router enable mode.
(2) Type, "eigrp stub" in R3 which will be stub router.

Check in router R1's route.

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/2300416] via 10.2.3.2, 00:00:14, Serial1/0
     100.0.0.0/24 is subnetted, 1 subnets
D       100.100.100.0 [90/2174976] via 10.2.3.2, 00:00:14, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.30.0.0/21 [90/2300416] via 10.2.3.2, 00:00:14, Serial1/0
D       172.30.8.0/24 [90/2300416] via 10.2.3.2, 00:00:14, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2172416] via 10.2.3.2, 00:56:25, Serial1/0
C       10.2.3.0 is directly connected, Serial1/0
------------------
  • You can't ping to R5 (100.100.100.5) becuase of it's behind stub router
  • Static route (3.3.3.3) is missing because default "eigrp stub" command means "eigrp stub connected summary"
  • That's why static router is missing but strangely summary route (172.30.0.0/21) is appearing because of summary key is included by default.
  • Let's try to type "eigrp stub static connected" and see in R1 routes.

--------
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/2300416] via 10.2.3.2, 00:00:11, Serial1/0
     100.0.0.0/24 is subnetted, 1 subnets
D       100.100.100.0 [90/2174976] via 10.2.3.2, 00:00:11, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2172416] via 10.2.3.2, 00:00:11, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     172.30.0.0/24 is subnetted, 9 subnets
D       172.30.2.0 [90/2300416] via 10.2.3.2, 00:00:11, Serial1/0
D       172.30.3.0 [90/2300416] via 10.2.3.2, 00:00:11, Serial1/0
D       172.30.0.0 [90/2300416] via 10.2.3.2, 00:00:11, Serial1/0
D       172.30.1.0 [90/2300416] via 10.2.3.2, 00:00:11, Serial1/0
D       172.30.6.0 [90/2300416] via 10.2.3.2, 00:00:12, Serial1/0
D       172.30.7.0 [90/2300416] via 10.2.3.2, 00:00:12, Serial1/0
D       172.30.4.0 [90/2300416] via 10.2.3.2, 00:00:12, Serial1/0
D       172.30.5.0 [90/2300416] via 10.2.3.2, 00:00:12, Serial1/0
D       172.30.8.0 [90/2300416] via 10.2.3.2, 00:00:12, Serial1/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2172416] via 10.2.3.2, 01:00:24, Serial1/0
C       10.2.3.0 is directly connected, Serial1/0
-----------
All 172.30.0.0 networks are appearing even though I summaried these.
Only one static route 3.3.3.3 is reappearing as EIGRP route.
OK, this time, try to type "eigrp stub received-only" in R3 router.
Check in R1 again.

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 2 subnets
D       10.2.2.0 [90/2172416] via 10.2.3.2, 01:04:54, Serial1/0
C       10.2.3.0 is directly connected, Serial1/0
------------------
All routes are gone only showing connnected routes 10.2.3.0, 172.16.1.0 and one EIGRP route
10.2.2.0 before stub router R3 appearing.
Stub router stop sending all routers and only received from others.

Sunday, February 6, 2011

Using OSPF special areas, authenication and virtual link

This lab will show you all in one about OSPF special areas, authentication between each routers and configuration of OSPF virtual link.

As the original lab is from CBT Nuggets and as it covered many topic, this lab is using eight routers :)

All configuration are exactly same as from CBT Nuggets video. For those who have video and don't have GNS3 files, download from below link.

https://docs.google.com/leaf?id=0B889ogd4ltI2MDQ2OTMyYjItZDEwYy00ZWY4LTk5OGMtNmQ3ZWI0NTVlZDBi&hl=en&authkey=CJ-w4LgI


BGP (ebgp-multihop) using static routes

This lab mainly for emulation in using "ebgp-multihop" and "static route " to reach to external network while one of the physical serial interface down.

As I am a newbie learning BGP, sometime it take time to understand how to use ebgp-multihop. I hope this lab can explain well.

Download complete GNS3 lab files from https://docs.google.com/leaf?id=0B889ogd4ltI2ZjYyMDVhZjQtYjY4OS00NDUwLWI4YmEtY2Q1ODcwYTY0YTUw&hl=en&authkey=CJeusKgO


















R1 is in AS 100 with following configuration.

Two serial interfaces with IP 2.2.2.1 and 1.1.1.1 for redundancy
Two loopback for testing ebgp multi hop. (10.10.10.10) and external network emulation for 150.10.1.1
--------------
R2 is in AS 200 with following config.
Two serial intefaces with IP 2.2.2.2 and 1.1.1.2 for redundancy
Two loopback for testing ebgp multi hop. (5.5.5.5) and external network emulation for 160.10.1.1
========================
Create EBGP neighbors using external IP of two routers.
Establish BGP neighbors. (noted that the lab is not using phyisical serial interfaces for BGP neighbor relationship becuase if one of the
physical inteface is down, BGP neighbor relationship will continue and next-hop address will update by itself to reach to external network)
---------------------

Configurations in R1
==============

router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.10 mask 255.255.255.255
 redistribute static
 neighbor 160.10.1.1 remote-as 200
 neighbor 160.10.1.1 ebgp-multihop 255
 neighbor 160.10.1.1 update-source Loopback0
----------
For static route configuration in R1 to reach external IPs.

ip route 160.10.0.0 255.255.0.0 1.1.1.2
ip route 160.10.0.0 255.255.0.0 2.2.2.2

================================================
Configuration in R2

router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.5 mask 255.255.255.255
 neighbor 150.10.1.1 remote-as 100
 neighbor 150.10.1.1 ebgp-multihop 255
 neighbor 150.10.1.1 update-source Loopback0
----------------
Static route will be configure as follow to reach to external IP through serial interfaces.

ip route 150.10.0.0 255.255.0.0 1.1.1.1
ip route 150.10.0.0 255.255.0.0 2.2.2.1
=============================================================
This is how I tested by shutting down s1/1 from AS 200 router.

Before shut down s1/1 from AS 200
R1#sh ip bgp
BGP table version is 6, local router ID is 150.10.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 5.5.5.5/32       160.10.1.1               0             0 200 i
*> 6.6.6.6/32       0.0.0.0                  0         32768 ?
*> 10.10.10.10/32   0.0.0.0                  0         32768 i
*> 160.10.0.0       1.1.1.2                  0         32768 ?
-----------
Note that to reach to 160.10.0.0, next hop address is 1.1.1.2

After shutdown s1/1 from AS 200,  next hop address has changed to 2.2.2.2 (s1/0) automatically to reach to external route 160.10.0.0/24

R1#sh ip bgp
BGP table version is 7, local router ID is 150.10.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 5.5.5.5/32       160.10.1.1               0             0 200 i
*> 6.6.6.6/32       0.0.0.0                  0         32768 ?
*> 10.10.10.10/32   0.0.0.0                  0         32768 i
*> 160.10.0.0       2.2.2.2                  0         32768 ?

Saturday, February 5, 2011

BGP (using next-hop-self)

After reading BGP, I was stopped for a while how to use "next-hop-self". If you still have same problem, below simple lab will help you, I believe.

Try to reach external networks (1.1.1.1) and (2.2.2.2) injected from R1 (AS 5500) from R3. Do not announce 200.100.10.0/24 network in AS 5000.

Download full GNS3 lab from https://docs.google.com/leaf?id=0B889ogd4ltI2YTM4OGE4MGUtZDYwNi00NDE0LTkxMTItYzJlMTcwNTYyZWNl&hl=en&authkey=CPi_26EP
























R1' BGP status.

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200.100.10.2    4  5000      10      12        3    0    0 00:06:18        0
--------
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback2
C    200.100.10.0/24 is directly connected, Serial1/0
===========================================
R2.

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.1.3     4  5000       0       0        0    0    0 never    Active
200.100.10.1    4  5500      14      12        3    0    0 00:04:12        2
-------------------
     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/0] via 200.100.10.1, 00:05:59
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 200.100.10.1, 00:04:59
C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    200.100.10.0/24 is directly connected, Serial1/0
---------

R2#sh ip bgp
BGP table version is 3, local router ID is 200.100.10.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.100.10.1             0             0 5500 i
*> 2.2.2.2/32       200.100.10.1             0             0 5500 i
======================================
R3.
R3#sh ip bgp
BGP table version is 1, local router ID is 192.168.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i1.1.1.1/32       200.100.10.1             0    100      0 5500 i
* i2.2.2.2/32       200.100.10.1             0    100      0 5500 i
-----
There is no best route. To fix this two things need to do; one is announce the network 192.168.1.0/4 in R2 and R3 using BGP or other routing protocol.

Second, configure R2 as next hop self addresss for R3.
-----
Action in R2 as follow.
R2(config-router)#neighbor 192.168.1.3 next-hop-self

Result showing in R3 as follow.
R3#sh ip bgp
BGP table version is 1, local router ID is 192.168.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i1.1.1.1/32       200.100.10.1             0    100      0 5500 i
* i2.2.2.2/32       200.100.10.1             0    100      0 5500 i
R3#sh ip bgp
BGP table version is 3, local router ID is 192.168.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.1/32       192.168.1.2              0    100      0 5500 i
*>i2.2.2.2/32       192.168.1.2              0    100      0 5500 i
(Best route appear in R3) but you can't ping to 1.1.1.1. Why?
It need to announce 192.168.1.0/24 as IGBP between R2 and R3.
In R2 announce the network as follow.
R2(config)#router bgp 5000
R2(config-router)#net
R2(config-router)#network 192.168.1.0 255.255.255.0
-------------
In R3...
R3(config)#router bgp 5000
R3(config-router)#network 192.168.1.0 mask 255.255.255.0
=====================================================
Check the  BGP routing tables in R2.

R2#sh ip bgp
BGP table version is 4, local router ID is 200.100.10.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.100.10.1             0             0 5500 i
*> 2.2.2.2/32       200.100.10.1             0             0 5500 i
* i192.168.1.0      192.168.1.3              0    100      0 i
*>                  0.0.0.0                  0         32768 i
------------------------
In R3 BGP routing table.
R3#sh ip bgp
BGP table version is 6, local router ID is 192.168.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.1/32       192.168.1.2              0    100      0 5500 i
*>i2.2.2.2/32       192.168.1.2              0    100      0 5500 i
*> 192.168.1.0      0.0.0.0                  0         32768 i
* i                 192.168.1.2              0    100      0
-----------
Best route and (i) internal route will appear and BGP will know how to route to two external routers (1.1.1.1) and (2.2.2.2)
Testing by pining.
-----
R3#ping 2.2.2.2


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/28 ms


R3#traceroute 2.2.2.2


Type escape sequence to abort.
Tracing the route to 2.2.2.2


  1 192.168.1.2 16 msec 20 msec 8 msec
  2 200.100.10.1 12 msec 8 msec *
===========================================
Using this topology will achive both IBGP and EBGP, how to use next-hop-self and external routes (200.100.10.0/24) is not needed to announce in internal network.

Friday, February 4, 2011

OSPF Stub, NSSA and Totally Stub Areas

I was confused after reading two areas; NSSA and totally stubby area. Check out the lab if you still have problem. Lab has configured only two Areas for simplicity. If anything in error, it was my fault.

Download the full GNS3 files from below link.
https://docs.google.com/leaf?id=0B889ogd4ltI2OGZkMjE0YzMtNWJmOS00OGE5LTgwOTItYTMxMGI4Y2RkZWVm&hl=en&authkey=CNL66bUL

Here is lab topology.











Area 0 is backbone and Area 1 will be test for stub, NSSA and totally stub areas.
First configured all three routers with loopback and redistribute all routes to OSPF.

Here are the results and OSPF database to understand more about LSA types.
----------
After configuration all three routers with "router ospf 1" and adding all connected and loopback networks plus redistributed static routers, all can ping each other and routing tables will be shown as below.

R1
   5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.10.0 [110/128] via 192.168.1.1, 00:17:28, Serial1/0
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback3
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.10.1.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
O E2    10.10.2.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
O E2    10.10.3.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
=================
R2

     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.10.0 [110/128] via 192.168.1.1, 00:17:28, Serial1/0
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback3
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.10.1.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
O E2    10.10.2.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
O E2    10.10.3.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0

=============
R3

     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.10.0 [110/128] via 192.168.1.1, 00:17:28, Serial1/0
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback3
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.10.1.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
O E2    10.10.2.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
O E2    10.10.3.0 [110/20] via 192.168.1.1, 00:16:32, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
=============
Configuration Area 1 as stub by adding configuration in R1 and R2 using "area 1 stub"
R2 Warning Message.
R2(config-router)#area 1 stub
Warning: Router is currently an ASBR while having only one area which is a stub area
------------
R1 ABSR Route after stub.
     5.0.0.0/32 is subnetted, 1 subnets
O E2    5.5.5.5 [110/20] via 192.168.1.3, 00:00:33, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O E2    6.6.6.6 [110/20] via 192.168.1.3, 00:00:33, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/1
     7.0.0.0/32 is subnetted, 1 subnets
O E2    7.7.7.7 [110/20] via 192.168.1.3, 00:00:33, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
---------------------------------------

R2 Route.

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.1.0 is directly connected, Loopback0
C       10.10.2.0 is directly connected, Loopback2
C       10.10.3.0 is directly connected, Loopback3
O IA 192.168.1.0/24 [110/128] via 172.16.10.1, 00:00:22, Serial1/0
O*IA 0.0.0.0/0 [110/65] via 172.16.10.1, 00:00:22, Serial1/0

--------------
R3 Route.

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.1.0 is directly connected, Loopback0
C       10.10.2.0 is directly connected, Loopback2
C       10.10.3.0 is directly connected, Loopback3
O IA 192.168.1.0/24 [110/128] via 172.16.10.1, 00:00:22, Serial1/0
O*IA 0.0.0.0/0 [110/65] via 172.16.10.1, 00:00:22, Serial1/0
------
Notice can't reach to external routers from Stub Area 10.10 network but ping can reach to external routes from Area 0 R3.

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.1.0 is directly connected, Loopback0
C       10.10.2.0 is directly connected, Loopback2
C       10.10.3.0 is directly connected, Loopback3
O IA 192.168.1.0/24 [110/128] via 172.16.10.1, 00:00:01, Serial1/0
O*IA 0.0.0.0/0 [110/65] via 172.16.10.1, 00:00:01, Serial1/0
R2#ping 5.5.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
-------

Check LSA routers in R1.

OSPF Router with ID (1.1.1.1) (Process ID 1)

Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         313         0x80000003 0x003B7C 2
3.3.3.3         3.3.3.3         263         0x80000004 0x007B30 2

Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.10.0     1.1.1.1         313         0x80000002 0x00F739

Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         196         0x8000000A 0x00EE0F 2
2.2.2.2         2.2.2.2         184         0x8000000A 0x008B6E 2

Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         1.1.1.1         213         0x80000001 0x0093A6
192.168.1.0     1.1.1.1         215         0x80000005 0x004745

Type-5 AS External Link States


Link ID         ADV Router      Age         Seq#       Checksum Tag
5.5.5.5         3.3.3.3         511         0x80000002 0x00A4DA 0
6.6.6.6         3.3.3.3         511         0x80000002 0x007605 0
7.7.7.7         3.3.3.3         511         0x80000002 0x00482F 0
-------------
LSA routers in R2
OSPF Router with ID (2.2.2.2) (Process ID 1)

Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         185         0x8000000A 0x00EE0F 2
2.2.2.2         2.2.2.2         171         0x8000000A 0x008B6E 2

Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         1.1.1.1         202         0x80000001 0x0093A6
192.168.1.0     1.1.1.1         202         0x80000005 0x004745
========================


Configuration NSSA in Area 1

Route in R3
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.10.0 [110/128] via 192.168.1.1, 00:01:33, Serial1/0
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback3
     10.0.0.0/24 is subnetted, 3 subnets
O E2    10.10.1.0 [110/20] via 192.168.1.1, 00:01:17, Serial1/0
O E2    10.10.2.0 [110/20] via 192.168.1.1, 00:01:17, Serial1/0
O E2    10.10.3.0 [110/20] via 192.168.1.1, 00:01:17, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
=============
Router in R1

     5.0.0.0/32 is subnetted, 1 subnets
O E2    5.5.5.5 [110/20] via 192.168.1.3, 00:00:12, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O E2    6.6.6.6 [110/20] via 192.168.1.3, 00:00:12, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/1
     7.0.0.0/32 is subnetted, 1 subnets
O E2    7.7.7.7 [110/20] via 192.168.1.3, 00:00:12, Serial1/0
     10.0.0.0/24 is subnetted, 3 subnets
O N2    10.10.1.0 [110/20] via 172.16.10.2, 00:00:12, Serial1/1
O N2    10.10.2.0 [110/20] via 172.16.10.2, 00:00:12, Serial1/1
O N2    10.10.3.0 [110/20] via 172.16.10.2, 00:00:12, Serial1/1
C    192.168.1.0/24 is directly connected, Serial1/0
--------
OSPF database in R1 include  L7 NSSA types.

         OSPF Router with ID (1.1.1.1) (Process ID 1)

Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         190         0x80000004 0x003F75 2
3.3.3.3         3.3.3.3         861         0x80000004 0x007B30 2

Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.10.0     1.1.1.1         910         0x80000002 0x00F739

Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         183         0x8000000E 0x00747B 2
2.2.2.2         2.2.2.2         183         0x8000000E 0x0011DA 2

Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.0     1.1.1.1         190         0x80000007 0x00CAB7

Type-7 AS External Link States (Area 1)


Link ID         ADV Router      Age         Seq#       Checksum Tag
10.10.1.0       2.2.2.2         198         0x80000001 0x00DBD4 0
10.10.2.0       2.2.2.2         198         0x80000001 0x00D0DE 0
10.10.3.0       2.2.2.2         198         0x80000001 0x00C5E8 0

Type-5 AS External Link States


Link ID         ADV Router      Age         Seq#       Checksum Tag
5.5.5.5         3.3.3.3         1108        0x80000002 0x00A4DA 0
6.6.6.6         3.3.3.3         1108        0x80000002 0x007605 0
7.7.7.7         3.3.3.3         1108        0x80000002 0x00482F 0
10.10.1.0       1.1.1.1         170         0x80000001 0x008E30 0
10.10.2.0       1.1.1.1         170         0x80000001 0x00833A 0
10.10.3.0       1.1.1.1         170         0x80000001 0x007844 0
===========
Router in R2

    172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.1.0 is directly connected, Loopback0
C       10.10.2.0 is directly connected, Loopback2
C       10.10.3.0 is directly connected, Loopback3
O IA 192.168.1.0/24 [110/128] via 172.16.10.1, 00:03:35, Serial1/0
-----------
LSA
R2#sh ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         250         0x8000000E 0x00747B 2
2.2.2.2         2.2.2.2         250         0x8000000E 0x0011DA 2

Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.1.0     1.1.1.1         258         0x80000007 0x00CAB7

Type-7 AS External Link States (Area 1)


Link ID         ADV Router      Age         Seq#       Checksum Tag
10.10.1.0       2.2.2.2         264         0x80000001 0x00DBD4 0
10.10.2.0       2.2.2.2         264         0x80000001 0x00D0DE 0
10.10.3.0       2.2.2.2         264         0x80000001 0x00C5E8 0
============
Result, ping can't reach to R3's extenal routes from  NSSA area
R2#ping 5.5.5.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
..
Success rate is 0 percent (0/2)
-----------
But area0 still can reach to external routers from NSSA area (not so stubby area).
----------------
Configuration Area 1 as totally stubby area as follows.

Totally Stub Area by adding "area 1 stub no-summary" in R1 and  "area1 stub" in R2.
Note that totally stubby area is Cisco properity and it should be configured only in ABR
R1 router after configuration totally stubby area 1.
     5.0.0.0/32 is subnetted, 1 subnets
O E2    5.5.5.5 [110/20] via 192.168.1.3, 00:10:37, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O E2    6.6.6.6 [110/20] via 192.168.1.3, 00:10:37, Serial1/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/1
     7.0.0.0/32 is subnetted, 1 subnets
O E2    7.7.7.7 [110/20] via 192.168.1.3, 00:10:37, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
--------------
R2 routing table.
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.10.0 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 3 subnets
C       10.10.1.0 is directly connected, Loopback0
C       10.10.2.0 is directly connected, Loopback2
C       10.10.3.0 is directly connected, Loopback3
O*IA 0.0.0.0/0 [110/65] via 172.16.10.1, 00:10:26, Serial1/0

All have one default IA routes only.
---------------
R3 (Area 0 ) routing table
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
O IA    172.16.10.0 [110/128] via 192.168.1.1, 00:10:26, Serial1/0
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback3
C    192.168.1.0/24 is directly connected, Serial1/0
-----------
R3 can't ping any external routers from Stubby area 1 but R3 (stub area 1 can ping from both internal and external routes from Area 0)
--------
Not-So-Stubby Areas (NSSA): An OSPF stub area has no external routes in it. A NSSA allows external routes to be flooded within the area. These routes are then leaked into other areas. This is useful when you have a non-OSPF router connected to an ASBR of a NSSA. The routes are imported, and flooded throughout the area. However, external routes from other areas still do not enter the NSSA
--------
Here is summary of LSA types.


AreaRestriction
NormalNone
StubType 5 AS-external LSA NOT allowed
NSSAType 5 AS-external LSAs are NOT allowed, but Type 7 LSAs that convert to Type 5 at the NSSA ABR can traverse
Totally StubbyType 3, 4 or 5 LSAs are NOT allowed except the default summary route