Thursday, October 27, 2011

CCNP TSHOOT - Ticket 1

I have a chance to download CCNP Tshoot GNS3 files from Internet to practice. I will not create new GNS3 files this time and I'll use the files which I found from Internet.

Use this link http://dl.dropbox.com/u/2749921/GNS_Tshoot.tar.gz to download all tickets. Thanks to the one who create all GNS3 files.

The lab topology is the same as you will see in exam.



All of the questions will ask you "client1 can't reach to WebSrv.

First of all, you need to check whether client1 has IP address or not. Check in console as follow.


Client1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.2.1.3        YES DHCP   up                    up  
FastEthernet0/1            unassigned      YES NVRAM  administratively down down


Client1 has IP address 10.2.1.3. Let's ping to 10.1.1.1 which is Router 1.

Client1#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Ping is failed. So, let's check whether client1 can reach to router 2 (10.1.1.2)


Client1#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 96/124/160 ms

Then, you know where is the problem. It's between R1 and R2. Let's check more the configuration of R1 and R2.


As the topology is OSPF, check whether R1 is neighbour with R2 or not.


R1#sh ip ospf neighbor


R1#

No neighbour fond in R1. So, let's move to R2.

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:00:33    10.1.1.6        Serial1/0.23


R2 has neighbour with R3 (3.3.3.3). So, the problem is R1's OSPF configuration.

Check R1's OSPF configuration as follow.


R1#sh run | in
R1#sh run | include ospf
 ipv6 ospf 6 area 12
 ip ospf message-digest-key 1 md5 TSHOOT
 ipv6 ospf 6 area 12
router ospf 1
ipv6 router ospf 6

Let's check again in R2.


R2#sh run | include ospf
 ipv6 ospf 6 area 0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 TSHOOT
 ipv6 ospf 6 area 12
 ipv6 ospf 6 area 0
router ospf 1
ipv6 router ospf 6
--------------------------
What is the difference? In R1, ip ospf authentication message-digest is missing.
That's it. So, the problem is in R1, it's OSPF configuration and you already know how to fix it.

As soon as you fixed, neighbour will established between R1 and R2 and you can reach to WebSrv.

59 comments:

  1. Thank you so much for this.
    I figured out how to load the main topology - how do i load each ticket?

    Any help is appreciated!

    ReplyDelete
  2. Hi, just download gz file from http://dl.dropbox.com/u/2749921/GNS_Tshoot.tar.gz. Extract using 7zip into one folder.
    Each tickets are in separate folders. Just double click the ".net" file and it will load the topology.

    ReplyDelete
    Replies
    1. Ferdaush, BangladeshNovember 19, 2012 at 4:10 PM

      Thanks, Thats great

      I was just change the IOS & IOS path in .net file.

      http://dl.dropbox.com/u/2749921/GNS_Tshoot.tar.gz


      working fine.

      Thanks
      Ferdaush

      Delete
    2. Ferdaush, BangladeshNovember 19, 2012 at 9:47 PM

      Image path should be like below: (use / )

      [localhost:7202]
      workingdir = working
      udp = 10200
      [[3660]]
      image = D:/IOS/C3660-JK.BIN
      idlepc = 0x6043ad80
      sparsemem = True
      ghostios = True
      chassis = 3660

      Nor like below:(not \ )

      [localhost:7202]
      workingdir = working
      udp = 10200
      [[3660]]
      image = D:\IOS\C3660-JK.BIN
      idlepc = 0x6043ad80
      sparsemem = True
      ghostios = True
      chassis = 3660

      Delete
  3. are this the exact exam tickets

    ReplyDelete
  4. Yes, I have passed in last 2 months ago.

    ReplyDelete
    Replies
    1. too bad! i thought this was just practice labs. cheat urself is not the way into networking.

      Delete
    2. What you mean, cheat yourself in networking. I am currently working in networking. I am just sharing the files that I practised by getting tickets from networktut. If you don't want to come, please walk away.

      Delete
  5. http://dl.dropbox.com/u/2749921/GNS_Tshoot.tar.gz. the link does't working
    please try to again upload,
    Thanks

    ReplyDelete
  6. Thank you, i downloaded already, but i can't mange where i have to keep the file, actually i'm not able to load the file into GNS3, so if you please describe how to work and define the place of your nice job,

    Kindly excuse me for that,

    ReplyDelete
  7. The lab is not opening. it showing a Dynamips error
    206-unable to create UDP NIO
    please what can I do
    thank you

    ReplyDelete
  8. I just downloaded your GNS3 labs and tried ticket #1. Everything went so smoothly. Thank you very much.

    ReplyDelete
  9. I downloaded the file but could not install it. when i try to install, it tells me IOS image cannot be found for the hypervisor localhost:7202 and cannot find alternative 3660 Image. Please can anyone kindly put me through on how to make this work?.
    Thanks

    ReplyDelete
  10. Hi Timothy,
    IOS image is also included in the zip file. Did you already check?

    ReplyDelete
  11. Hi, i went to the IOS images and hypervisor/settings and image file in EDIT and added the 3660 ios image in the ZIP file downloaded but still cant get it to work. how do i load the tickets please?

    ReplyDelete
  12. hi Myo Gyi
    I also face the same situation as timothy ...please assist

    ReplyDelete
  13. can you please tell me in GNS how I can set the pc idle value without doing it each time I start a sim?

    ReplyDelete
  14. @delraykid,

    Hope this Youtube video can help you to solve idle value.
    http://www.youtube.com/watch?v=NkEv6v6rqlA&feature=player_embedded

    ReplyDelete
  15. @Rob, Delrakid,
    Can you please send me screen shot of the errors details, pls.

    ReplyDelete
  16. @Rob, Delrakid,
    Make sure to change the image path as below according to your path.

    autostart = False
    [localhost:7202]
    workingdir = working
    udp = 10200
    [[3660]]
    image = D:\CISCO\GNS3\IOS\C3660-JK.bin

    ReplyDelete
  17. I had previously fixed the image path, so it is pulling an IOS image..however I get this error:

    Dynagen management console for Dynamips (adapted for GNS3)
    Copyright (c) 2006-2011 GNS3 Project

    => Warning: using localhost in your topology file is not recommended
    Warning: using localhost in your topology file is not recommended
    Warning: using localhost in your topology file is not recommended

    ************************************
    Thanks for the help!!

    ReplyDelete
  18. You need to change from localhost to 127.0.0.1 in .NET file.
    Check more in http://forum.gns3.net/topic3639.html

    ReplyDelete
  19. Changed the file from "localhost" to 127.0.0.1..got rid of the error messages however still have cpu utilization issue...watched Utube video..for some reason even if I save the new idlepc value (and verify after rebooting routers) I still need to recalculate idle pc...oh well...I'll keep playing with it..thanks!

    ReplyDelete
  20. This site is awesome...I can already complete the 10 TT's on this site! One question...I see there are possibly a total of 14 TT's presented in the TShoot exam..do you know if anyone has configured GNS3 for the other 4 tickets? Thanks!

    ReplyDelete
  21. Delraykid,

    There are total 13 tickets in the zip file you downloaded. I have't uploaded for other tickets. Not sure for another one ticket.

    I'll upload later.

    ReplyDelete
  22. Hmmm....I'm only seeing 10 tickets...if I could I'd send you a screenshot.

    I downloaded this from your Dec 14th post:
    http://dl.dropbox.com/u/2749921/GNS_Tshoot.tar.gz

    ReplyDelete
  23. Ah, yes. You are right.
    I have created other three tickets by myself based upon the questions from http://www.networktut.com/

    ReplyDelete
  24. :-) Well at least I know I'm not losing my mind..yet. Please let me know when you have posted the update! Thanks!

    ReplyDelete
  25. Myo, i'm still unable to solve the problem. i uninstalled the GNS3 and downloaded a new one but still facing the same issue. kindly please tell me a step by step procedure on how to set up the TTs on the GNS3. all efforts appreciated.

    ReplyDelete
  26. if gns3 gives some errors, try to edit topology.net file with wordpad.

    Fist: You should change the ios path with your correct ios directory.
    like this "image = C:\Users\kadir\Desktop\gns3\imagelar\C3660-JK.BIN"

    And put the new ios your ios directory.


    Second:You should change config path with your correct config directory.

    TSHOOT_configs/---->TSHOOT_configs\


    Last: Change localhost->127.0.0.1

    Regards

    ReplyDelete
  27. thanks so much everyone for your contribution. passed the Tshoot exams today with 945/1000

    ReplyDelete
  28. @Thimothy...Glad to hear that you passed Tshoot and finally become CCNP

    ReplyDelete
  29. hi guys
    I download the topology and successfully loaded it. the client and other routers have no configuration. Example client one does not have any Ip adress set on the fa0/0. can someone tell how if it because of the fact that it was not set on gns3 topology or anything else

    ReplyDelete
  30. Hi,
    Sometime you will see Client1 get IP address and in some lab files, it wont.
    This is the question why IP address not get.

    Try to get IP address in Client 1 first.
    Then, try to ping Web server. If you can't, this is the starting point and look for way to find where is the error. Fix it and test can ping to Web server or not.
    In exam, you don't need to fix but you have to select the steps how you will fix.

    ReplyDelete
    Replies
    1. I downloaded the labs but in ALL the 10 tickets the Client1 has NOT been assigned the ip (10.2.1.3).

      Also I cant see any vlans configured. My output doesnt match the show ip eigrp neighbors output regarding VLANs.

      Can anyone help please.

      Delete
  31. Hi Myo Gyi,

    I'm preparing for Tshoot exam
    Ur's Lab is very useful.

    Please join me on Linkedin
    http://sg.linkedin.com/in/nandakyaw

    Thanks

    ReplyDelete
  32. Myo Gyi,

    What is the exact name of the image file you used for your GNS3 topology? The one you provided seems to be corrupted so I am using a different one.

    Currently I am using c3660-a3jk9s-mz.124-25d.image but it seems to be giving me issues on some of the tickets.

    Thanks in advance if you can provide that and thanks for setting up this blog for everyone!

    ReplyDelete
  33. Hi,
    IOS file C3660-JK.BIN has included in GNS_Tshoot.tar.gz file. Please use it.

    ReplyDelete
  34. I haven't been abale to bring HSRP between DSW1 and DSW2 over the routed port. Can someone help please?

    ReplyDelete
  35. I was able to load everything but client1 is not able to execute ipconfig, it has 3600 image.

    ReplyDelete
  36. Ah, you can't execute "ipconfig" in Client1. It's router. So just type "sh ip int brief" and check whether fa0/0 has ip address or not. If not, wait for a while and check again.

    ReplyDelete
  37. Thats what I've been doing, just thought i was doing something wrong. Thank you.

    ReplyDelete
  38. Myo Gyi

    I downloaded the labs but in all the 10 tickets the Client1 has NOT been assigned the ip (10.2.1.3).

    Also I cant see any vlans configured. My output doesnt match the show ip eigrp neighbors output regarding VLANs.

    Help please.

    ReplyDelete
  39. where is the detail explanation of above network diagram. From figure it's hard to identify which router is running which protocol

    ReplyDelete
  40. @Stylesp: You have to run "Show run" command on R1 2 3 4 routers. or "Show ip protocols" command.

    ReplyDelete
  41. Did anyone noticed that in this LAB, the BGP network statement was not OK in ROutside:

    ROutside#show running-config | section bgp
    router bgp 65002
    no synchronization
    bgp log-neighbor-changes
    network 209.65.200.224 mask 255.255.255.252
    redistribute connected
    neighbor 209.65.200.225 remote-as 65001
    neighbor 209.65.200.225 soft-reconfiguration inbound
    no auto-summary

    to fix this:
    ROutside(config-router)#no network 209.65.200.224 mask 255.255.255.252
    ROutside(config-router)#network 209.65.200.240 mask 255.255.255.248
    ROutside(config-router)#end
    ROutside#

    ReplyDelete
  42. sorry guys, my mistake, didn't notice this:

    redistribute connected

    Cheers :)

    ReplyDelete
  43. Hey Guys, Thanks for this files. But, I already downloaded it, saved in on file, but can't open it. It's showing permission denied. I'm able to open old labs, but unable to open for TSHOOT exam... Really don't know what's going on. I already tried to change the IOS image on net file...what should I type on working directory? I'll appreciate any help... thanks guys.

    ReplyDelete
  44. find and replace

    /Users/scoch/Dropbox/GNS3/IOS/C3660-JK.BIN

    C:\Users\Laptop\Desktop\GNS3\IOS\C3660-JK.BIN

    ReplyDelete
  45. Please help me use the GNS3 for TShoot ... i have downlaoded the file from the lonk provided.

    ReplyDelete
  46. Hi Geetha08kb,
    Using GNS3 straight forward. There are many Youtube videos how to use GNS3.

    ReplyDelete
  47. BTW in all tickets client should have set default-gateway to 10.2.1.254 which is HSRP address not 10.2.1.1 as you already defined
    Please correct it as below:
    ip dhcp pool CLIENTS
    network 10.2.1.0 255.255.255.0
    default-router 10.2.1.254

    ReplyDelete
  48. Hello Myo Gyi

    Please provide link to download remaining 4 tickets. Currently i have only 10 tickets.

    Thanks for your effort

    ReplyDelete
  49. You can check the tickets on digitaltut.com

    BTW - DHCP doesnt work, even after changing:
    ip dhcp pool CLIENTS
    network 10.2.1.0 255.255.255.0
    default-router 10.2.1.254

    On R4

    ReplyDelete
  50. Myo, All,
    I simply cannot get this to work at all. I've followed the following instructions however I am still getting an error message: error 206-unable to create UDP NIO. Any advice?

    start of instructions followed:
    if gns3 gives some errors, try to edit topology.net file with wordpad.

    Fist: You should change the ios path with your correct ios directory.
    like this "image = C:\Users\kadir\Desktop\gns3\imagelar\C3660-JK.BIN"

    And put the new ios your ios directory.

    Second:You should change config path with your correct config directory.

    TSHOOT_configs/---->TSHOOT_configs\

    Last: Change localhost->127.0.0.1

    ReplyDelete
  51. Hi,

    error 206-unable to create UDP NIO is not because of different paths in config and IOS.

    It's because of UDP ports used by Dynampis as mentioned in GNS3 forum.

    http://forum.gns3.net/topic4538.html
    - Used admin right if you are using Linux
    - Checked UDP port currently in used in your PC and change different UDP port used by GNS3.

    ReplyDelete
  52. Anyone has all 14 tickets in lab format?
    Networktut site is suspended and digitaltut doesn't seem to have them all.
    Thanks in advance.

    ReplyDelete
  53. Myo,
    Other than idle pc, is there anything else that i could do to help with the CPU consumption?
    I'm using idle pc but my cpu is still at 100%.
    I have 4GB of RAM and using an Intel Core i5 CPU.

    ReplyDelete
  54. Thanks!

    I´ve developed a TSHOOT Strategy, see more at www.n3networkweb.com.

    I hope it helps you!

    ReplyDelete