The problem state that DSW1 and DSW2 are configured as HSRP routes and DSW1 should be active router but instead, currently DSW2 is active.
Let's check DSW1's HSRP configuration.
DSW1#sh standby
Vlan10 - Group 10
State is Standby
4 state changes, last state change 00:02:07
Virtual IP address is 10.2.1.254
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.772 secs
Preemption enabled
Active router is 10.2.1.2, priority 100 (expires in 7.736 sec)
Standby router is local
Priority 90 (configured 150)
Track object 1 state Down decrement 60
IP redundancy name is "hsrp-Vl10-10" (default)
Yes, DSW1 is currently standby and not active router. Active router is 10.2.1.2 which is DSW2.
Let's check more detail of DSW1's HSRP configuration in VLAN 10.
DSW1#sh run int vlan 10
Building configuration...
Current configuration : 191 bytes
!
interface Vlan10
ip address 10.2.1.1 255.255.255.0
ip helper-address 10.1.4.5
standby 10 ip 10.2.1.254
standby 10 priority 150
standby 10 preempt
standby 10 track 1 decrement 60
end
---------------------------------------
Pay attention to "standby 10 track 1 decrement 60" which means it need to check more on "Track 1".
Let's check more from running-config.
DSW1#sh run | begin track
track 1 ip route 4.4.4.1 255.255.255.255 metric threshold
threshold metric up 1 down 2
!
track 10 ip route 4.4.4.4 255.255.255.255 metric threshold
threshold metric up 111 down 112
-----------------------
Two track objects are configured; track1 and track 10. Tracking objects are tracking to ip reachable to ip 4.4.4.4 which is the loopback IP of R4.
Metric threshold means if it's reachable, default "UP" value is 254 and "DOWN" value is 255
So, current DSW1 track object is 1 and it's tracking route to 4.4.4.1 which is unavailable. That's why, current DSW1's priority value will be (150 - 60 = 90) which is lower than the DSW2, which has default value 100.
It's mentioned in DSW1 's "sh standby" output.
Priority 90 (configured 150)
Track object 1 state Down decrement 60
IP redundancy name is "hsrp-Vl10-10" (default)
------------------------------------------------------
To fix it, change standby 10 track 1 decrement 60 DSW1's interface vlan 10 as follow.
DSW1(config)#int vlan 10
DSW1(config-if)#no standby 10 track 1 decrement 60
DSW1(config-if)#standby 10 track 10 decrement 60
------------------
Check again in DSW1 whether it's active or not
DSW1#sh standby
Vlan10 - Group 10
State is Active
5 state changes, last state change 00:00:47
Virtual IP address is 10.2.1.254
Active virtual MAC address is 0000.0c07.ac0a
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.116 secs
Preemption enabled
Active router is local
Standby router is 10.2.1.2, priority 100 (expires in 8.184 sec)
Priority 150 (configured 150)
Track object 10 state Up decrement 60
IP redundancy name is "hsrp-Vl10-10" (default)
Just wanted to say 'Thank You' for your time & effort in creating these labs
ReplyDeleteMuch appreciated
u can change prority to DSW 1 till 200
ReplyDeletereally much appreciated.....
ReplyDeletereally much appreciated , I would say one of the best tshoot labs simulation that I have seen and used..
ReplyDeleteThank You Very Much Indeed.
ReplyDeleteThis comment has been removed by the author.
ReplyDeleteHi,
ReplyDeleteThanks for the labs. They are very useful. I read this excercise but it is not really clear how the track concept is working.
You wrote that
´Metric threshold means if it's reachable, default "UP" value is 254 and "DOWN" value is 255´
Allow me to extend the concept. Considering that we are using the defaul value for the tracked threshold, we have:
255 is unreacheble route (DOWN threshold)
254 is for reacheble route (UP treshold)
Does not matter the value of the metric, becasue we are using default value.
Go back to the lab.
Two are the routes tracked:
4.4.4.1 255.255.255.255
4.4.4.4 255.255.255.255
The 4.4.4.1 is an unreacheble route. No one has any interface with such ip.
The 4.4.4.4 255.255.255.255 is a reacheble route.
4.4.4.1 -> Unreacheble, so the DOWN threshold has automatically value 255. Now we should check the metric for this route on DSW1 and compare the value with the DOWN threshold but in this case we do not have the route 4.4.4.1 in the routing table, so we do not have a metric value.
In terms of tracked object this means metric=thershold=255 = state DOWN -> Decrement the priority of HSRP of 60.
4.4.4.4 -> Is reacheable and in your lab this route has a metric of 156160 but we need to normalise this value 156160/2560= 61. So, in terms of tracked object this metric is egual to 61.
Applying now the threshold for tracked object 10 we have
metric up 111 down 112
In our case the metric is 61, so below the value of the UP threshold (111) for this reason the tracked object will be
up -> Running Priority+60 = 90+60=150.
DSW1 will be active. (DSW2 has a priority of 100)
Hi
ReplyDeleteI have set up HSRP in GNS3 however find difficulty in understanding the track metric threshold scenario.
I feel like I have been missing something. Please can paste the configuration for DSW2.
Hi Anonymous. Really appreciate in putting more info about track values.
ReplyDeleteHi Harikrishna, DSW2 config is the same as original and nothing to do with it. Only thing to do in this ticket is just change the track value in DSW1.
Hi,
ReplyDeletewhere I could download the GNS file ?
Thanks
Dan
Hi,
ReplyDeleteAll tickets can download from http://dl.dropbox.com/u/2749921/GNS_Tshoot.tar.gz
This comment has been removed by the author.
ReplyDelete